Itero connection issue.
Identified·Partial outage

Itero connection issue still persists.

The fix is expected live not earlier than 12th of July.

Wed, Jun 25, 2025, 10:57 AM
(2 weeks ago)
·
Affected components
Updates

Identified

Itero connection issue still persists.

The fix is expected live not earlier than 12th of July.

Wed, Jun 25, 2025, 10:57 AM

Resolved

No issues with iTero identified.

Wed, Jun 25, 2025, 08:44 AM(2 hours earlier)

Investigating

The Itero account can not be connected.

Fri, May 2, 2025, 12:30 PM(1 month earlier)