iTero have experienced issues with not receiving STL's

Incident Report for GreatLab Status Page

Resolved

We have been informed this should be resolved but as an external element we have limited oversight.
Posted Mar 06, 2026 - 14:33 UTC

Monitoring

Itero have informed us this issue is fixed.
Posted Mar 05, 2026 - 14:56 UTC

Investigating

In the itero platform there is some users reporting issues with not receiving STL files.
Posted Mar 05, 2026 - 14:53 UTC
This incident affected: iOS Scanners (iTero).