System Performance Issue

Incident Report for GreatLab Status Page

Resolved

This incident has been resolved and logged. We apologise for the inconvenience this has caused.

We thank you for your patience with us on this matter.
Posted Mar 25, 2026 - 18:31 UTC

Update

We are continuing to investigate this issue.
Posted Mar 25, 2026 - 16:06 UTC

Investigating

We’re currently seeing slower than normal performance in our US region, linked to database response times. You may notice delays when loading or processing within the system.

The team is actively investigating and working to resolve this as quickly as possible. Further updates will be shared as we progress.
Posted Mar 25, 2026 - 15:49 UTC
This incident affected: US Hosting (Platform).